Search in
VALENTINE'S DAY Video Games TV Computers Finance Home Apparel Tech Cameras Autos Health & Beauty Children Entertainment Travel Pets
Popular Deal

Ployer MoMo8 (Business Edition) 8" Android Tablet -Ice Cream Sandwich (ICS 4.0.1) 1.2Ghz CPU, Full Android Market, HDMI, 5-Point Capacitive, 8GB NAND Flash -$145.99 Shipped, 5 Days

Evo-IC 4,611 February 21, 2012 at 11:07 PM in Computers (13)
Deal
Score
+75
164,629 Views
Get Deal

Deal Details

Last Edited by Evo-IC February 21, 2012 at 11:49 PM
It's been a long while since I posted an Android tablet deal, but this one was solid and I can vouch for the product, so here's the link:

Ployer MoMo8 - $149.99 [mcbub.com]

Coupon code available on Retailmenot.com takes another $4 off and this tablet should qualify.
Code: DVVCH5R2 - (Please post if it's not valid!)

Final price: $145.99 Shipped Free to the US.

See Wiki below for Specs.

- - Posted a video here: http://www.youtube.com/watch?v=M4zxLnMJ7Lw - -

1,072 Comments

68 69 70 71 72

Sign up for a Slickdeals account to remove this ad.

#1036
Quote from Ragonfe View Post :
The problem that I have now is with the livesuit. I want to format the tablet but when I try to connect my tablet using the usb cable( livesuit is open in the background) the first think that appears is the exclamation mark with no text, and then nothing happens. It seems like livesuit is not able to recognise my tablet, so in that case I can not do anything ( downgrade, upgrade, format,...)
Please I need help.
With the tablet plugged in and connected via USB, can see it in your Device Manager in XP? If you see it, highlight it and delete it. Reboot your pc and start over. I am thinking that Windows XP should reload the device.

Sometimes, plugging it into another USB jack on your pc might work too if it's not getting recognized correctly.
Reply Helpful Comment? 0 0
#1037
trying to download latest firmware from Ployer website.
says i have 2 days and 11 hours left.
anyone have a faster way to get it?
Reply Helpful Comment? 0 0
#1038
Were u able to flash this image on ur device??, livesuit refuses to recognize the image i downloaded , i downloaded twice with the same result, i would appreciate if u could upload ur working image on mediafire. I believe this is 4.0.4??,correct me if i'm wrong.

Quote from vampirefo View Post :
It's on ployers main site, I am on cell phone so can't post link. Latest version now allows network locations to work plus other fixes.

http://en.ployer.cn/uploadfile/20...120331.rar

http://en.ployer.cn/support.php?page=1
Last edited by bngguy April 26, 2012 at 09:47 PM
Reply Helpful Comment? 0 0
#1039
Quote from TwincH View Post :
With the tablet plugged in and connected via USB, can see it in your Device Manager in XP? If you see it, highlight it and delete it. Reboot your pc and start over. I am thinking that Windows XP should reload the device.

Sometimes, plugging it into another USB jack on your pc might work too if it's not getting recognized correctly.
Hi, when I connect my tablet with my computer I can no see it, desides the "USB Device (VID_1f3a_PID_efe8)" has an exclamation mark, so it does not work properly. Can you see me how I can fix it, or can someone post the correct drivers to make it by a manual installation.

Thank you very much
Reply Helpful Comment? 0 0
#1040
Mr. Vampire Fo,
you have been most helpful till now, so i am hoping u can solve this issue too.
i already downgraded to 2.3.4, now when i try to upgrade- i am using the file downloaded from the ployer website. (with livesuit 1.9) problem is after my computer loads the drivers, i get a message that the IMG file is "unavailable" and livesuit resets. this as happened on every computer i've tried it on, and with three different downloads of the file.
any ideas?
Reply Helpful Comment? 0 0
#1041
Quote from skeets2 View Post :
Mr. Vampire Fo,
you have been most helpful till now, so i am hoping u can solve this issue too.
i already downgraded to 2.3.4, now when i try to upgrade- i am using the file downloaded from the ployer website. (with livesuit 1.9) problem is after my computer loads the drivers, i get a message that the IMG file is "unavailable" and livesuit resets. this as happened on every computer i've tried it on, and with three different downloads of the file.
any ideas?
in reply to my own question (which i've noticed a few other asked before):
1) change the name of the .IMG to take out all Chinese characters (i renamed it "momo8 ics firmware")
2) move the file out of the folder it came in (it also has chinese characters- i moved it to my desktop)
3) upgrade with livesuit following instructions posted all over this thread.
Reply Helpful Comment? 0 0
#1042
Quote from skeets2 View Post :
in reply to my own question (which i've noticed a few other asked before):
1) change the name of the .IMG to take out all Chinese characters (i renamed it "momo8 ics firmware")
2) move the file out of the folder it came in (it also has chinese characters- i moved it to my desktop)
3) upgrade with livesuit following instructions posted all over this thread.

Thanks, that worked.
Reply Helpful Comment? 0 0

Sign up for a Slickdeals account to remove this ad.

#1043
I'm posting a dropbox link for the latest firmware https://www.dropbox.com/sh/j6163e...FKQr1czAUG
Reply Helpful Comment? 0 0
#1044
Hi guys can someone give me a tutorial to connect a 3g donge?
I ve tried by me own but I could not do it.
Please give me help!!!
thank you
Reply Helpful Comment? 0 0
#1045
Quote from bngguy View Post :
I'm posting a dropbox link for the latest firmware https://www.dropbox.com/sh/j6163e...FKQr1czAUG
Ran it as admin under Windows 7 Ultimate but it will not install drivers.

control Panel shows: USB Device(VID_1f3a_PID_efe8) with a yellow alert

Has anyone gotten to work ?
Reply Helpful Comment? 0 0
#1046
Quote from freebate View Post :
Ran it as admin under Windows 7 Ultimate but it will not install drivers.

control Panel shows: USB Device(VID_1f3a_PID_efe8) with a yellow alert

Has anyone gotten to work ?
ok vompiero's post said to"press an hold power for 15 seconds let go, then hold menu down then plug in usb then tap power until you get popup box. Let go of menu and click popup screen and follow onscreen directions". That worked. Instruction in the dropbox file did not install USB driver.
Reply Helpful Comment? 0 0
#1047
Quote from freebate View Post :
ok vompiero's post said to"press an hold power for 15 seconds let go, then hold menu down then plug in usb then tap power until you get popup box. Let go of menu and click popup screen and follow onscreen directions". That worked. Instruction in the dropbox file did not install USB driver.
I downloaded the image and instructions from ployer's website and uploaded to dropbox, i did not change anything, i was able to get it to work on Windows 7 Home premium.
Reply Helpful Comment? 0 0
#1048
Once I changed the chinese figures in the file, worked well for me.
Reply Helpful Comment? 0 0
#1049
Is this still a good deal for $149?
Reply Helpful Comment? 0 0
#1050
Quote from Grayson73 View Post :
Is this still a good deal for $149?
no way. definitely not a good deal now. imo it wasnt to start with but thats just my personal opinion.
Reply Helpful Comment? 0 0
Page 70 of 72
68 69 70 71 72
Join the Conversation
Add a Comment
 
Slickdeals Price Tracker
Saving money just got easier.
Start Tracking Today
Copyright 1999 - 2016. Slickdeals, LLC. All Rights Reserved. Copyright / Infringement Policy  •  Privacy Policy  •  Terms of Service  •  Acceptable Use Policy (Rules)