Forum Thread

4MyRebate lost submissions

bb182 6,163 6,483 September 13, 2013 at 11:40 PM
Please post here if you've had 4MyRebate submissions go missing so we can figure out what's going on.

Please include the date of mailing (week is fine if you are concerned about privacy). Other information like offer number, processing center (El Paso or San Diego), and resolution would also be helpful. Keep in mind that this page is visible to TD / 4MyRebate and that certain combinations of information may identify you.
Select the week of mailing for lost submissions.
June 2 - 8 (0)
0%
June 9 - 15 (0)
0%
June 16 - 22 (0)
0%
June 23 - 29 (5)
22%
June 30 - July 6 (2)
9%
July 7 - 13 (2)
9%
July 14 - 20 (2)
9%
July 21 - 27 (0)
0%
July 28 - Aug 3 (2)
9%
Aug 4 - 10 (0)
0%
Aug 11 - 17 (1)
4%
Aug 18 - 24 (5)
22%
Aug 25 - 31 (3)
13%
Sept 1 - 7 (7)
30%
Return to Poll

Community Wiki

Last Edited by bb182 October 30, 2013 at 03:01 PM
Rebates mailed during the last week of June into early July:
Many submissions mailed during this time were lost. It initially appeared to be a one-time problem related to the switch to the new El Paso processing center. There have been some reports of ongoing issues but so far it doesn't seem comparable to this incident.


Resubmission address (call 800-286-9146 first so they know you will resubmit):
Rebate Processing
P.O. Box 1339
Deerfield Beach FL 33443

(although I changed "Rebate Processing" to "Resubmissions" based on http://slickdeals.net/forums/showpost.php?p=61452214&postcount=53)

Old address per Andy11 on 10/30



Resubmission fax (call 800-286-9146 first):
I resubmitted, but my invoice was not scanned in. I was allowed to fax in the re-re-submission.
954-573-6751 (put Tracking Number on fax cover)

76 Comments

1 2 3 4 5

Sign up for a Slickdeals account to remove this ad.

Joined Dec 2010
L8: Grand Teacher
3,497 Posts
1,935 Reputation
#3
Thanks bb182 for posting a thread for 4Myrebate discussion!

Please notice! Don't disclosure too much personal information here as we all knew that there are TD employees watching SD.

Full Disclosure, I have received all of my rebates up to now and no lost mails yet.
Reply Helpful Comment? 0 0
Joined Aug 2012
L10: Grand Master
6,163 Posts
6,483 Reputation
Original Poster
#4
Hopefully the above poll doesn't turn out to be a bad idea. It doesn't look like I can edit it.

No lost rebates here.
Reply Helpful Comment? 0 0
#5
OK, guess I'll kick off. I've done about 20 TD rebates over the last few months (have many backlogged I still need to send out!) and so far I've only had one not come back. It's stuck in "Claim Completed, Awaiting Receipt of Documentation". I have gotten back all the other rebates I sent out that same day. All of them were processed properly and went through all the normal stages as noted on their website. I called 4Myrebate today and they told me my only recourse is to mail copies of my rebate documents to their main center in Deerfield, Florida.

Product: OEM 120mm Case Fan
Offer code: TD-10176
Date mailed: July 28 - Aug 3
Processing center: El Paso, TX
Resolution: none, will resubmit soon
Reply Helpful Comment? 0 0
Joined Nov 2011
Your Humble SD Servant
5,985 Posts
2,814 Reputation
#6
I've technically only had one rebate lost, and I realized my mistake in the other rebates while resubmitting them (I used the same TD Offer # on those other lost rebates as I did with one rebate) .. you can't get any stupider than that Facepalm

LMAOLMAOlaugh out loudlaugh out loudlaugh out loudLMAOLMAO
Reply Helpful Comment? 0 0
#7
TD-10634 / Kingwin 120mm Fan
El Paso, TX
Mailed around 08/20

When I emailed them, their reply was to resubmit to the original TX address, not the FL one in the wiki:
Quote :
Processing Department / Resubmissions
P.O. Box 130019, El Paso, TX 88513-0019 (No Wait)
P.O Box 130018, EL, Paso, TX 88513-0018 (Basic)
Reply Helpful Comment? 0 0
#8
I mailed 3 on 08/20 - all 3 had problems - 1st the solid gear was partly my fault - I mailed confirmation instead of invoice (never had to mail invoice before) - remailed invoice & now appears they are reprocessing rebate. -

TD-10253 - they claim they didn't receive - was a 60 day postmark requirement from 07/05
TD-10247 - they claim they didn't receive - was a 60 day postmark requirement from 07/05

what is odd about the last 2 which were both mailed the same day on 08/20 - both from 07/05 purchases is one of them shows status as actually denied & the other shows that they never received documents? She claims they never got documents on both of them, then why is one denied? do they routinely go in and mark denials on items never mailed in? - mailed copies of both today - she said to TX address - will see what happens
Reply Helpful Comment? 0 0
#9
I mailed a total defense rebate on Aug. 9 and they have never "received" it. So they asked me to fax the copy and now it was marked as "invalid" because invalid postmark date. I called again and the CSR asked me if I still remember when I mailed it the 1st time. He entered the Aug. 9 into the system and asked me to wait for at least 2 business days to see if the vendor would correct it grrrMad

Quote from alaynarenee View Post :
I mailed 3 on 08/20 - all 3 had problems - 1st the solid gear was partly my fault - I mailed confirmation instead of invoice (never had to mail invoice before) - remailed invoice & now appears they are reprocessing rebate. -

TD-10253 - they claim they didn't receive - was a 60 day postmark requirement from 07/05
TD-10247 - they claim they didn't receive - was a 60 day postmark requirement from 07/05

what is odd about the last 2 which were both mailed the same day on 08/20 - both from 07/05 purchases is one of them shows status as actually denied & the other shows that they never received documents? She claims they never got documents on both of them, then why is one denied? do they routinely go in and mark denials on items never mailed in? - mailed copies of both today - she said to TX address - will see what happens
Reply Helpful Comment? 0 0

Sign up for a Slickdeals account to remove this ad.

Joined Aug 2012
L10: Grand Master
6,163 Posts
6,483 Reputation
Original Poster
#10
Quote from alaynarenee View Post :
I mailed 3 on 08/20 - all 3 had problems - 1st the solid gear was partly my fault - I mailed confirmation instead of invoice (never had to mail invoice before) - remailed invoice & now appears they are reprocessing rebate. -

TD-10253 - they claim they didn't receive - was a 60 day postmark requirement from 07/05
TD-10247 - they claim they didn't receive - was a 60 day postmark requirement from 07/05

what is odd about the last 2 which were both mailed the same day on 08/20 - both from 07/05 purchases is one of them shows status as actually denied & the other shows that they never received documents? She claims they never got documents on both of them, then why is one denied? do they routinely go in and mark denials on items never mailed in? - mailed copies of both today - she said to TX address - will see what happens
The reason you haven't had problems with using the order confirmation before is that many TD-xxxxx offers allow it. They typically allow a seemingly random combination of invoice/receipt, order confirmation, and packing slip. Invoice/receipt are always there. The other ones vary but are often there.

They're not consistent about it, but they do deny rebates if documents are never received.
Reply Helpful Comment? 0 0
#11
I had a little trouble with a OCZ 650 Watt fan rebate, and a Zalman case rebate I did around the end of August. They seemed to find everything within a few days of sending an e-mail. Maybe they were just backlogged and would have gotten to them anyhow, but since it was getting close to the last day for submission I sent them an e-mail anyhow.
Reply Helpful Comment? 0 0
#12
Maybe this is outdated now, but I mailed 3 batches of rebates (16 total) between 09/12 and 09/23, all were lost. Had to resubmit to Florida address.
Reply Helpful Comment? 0 0
Joined Dec 2010
L8: Grand Teacher
3,497 Posts
1,935 Reputation
#13
I have 3 rebates that were lost. I will need to contact TD to resolve this through resubmission.
Reply Helpful Comment? 0 0
#14
Quote from kumo View Post :
When I emailed them, their reply was to resubmit to the original TX address, not the FL one in the wiki:
Update: I re-submitted to the TX address, and after 3+ weeks of the re-submission going nowhere (lost again? really?), I re-re-submitted via fax. A few days later, they finally approved it.
Reply Helpful Comment? 0 0
Joined Nov 2011
Your Humble SD Servant
5,985 Posts
2,814 Reputation
#15
9/23 was a huge hit for me. 6 TD rebates got lost and 2 Total Defense rebates got lost Frown
Will be resending them tomorrow or something ...

Maybe mailing around the 23rd of each month is bad luck or something??
Reply Helpful Comment? 0 0
Page 1 of 6
1 2 3 4 5
Join the Conversation
Add a Comment
 
Copyright 1999 - 2016. Slickdeals, LLC. All Rights Reserved. Copyright / Infringement Policy  •  Privacy Policy  •  Terms of Service  •  Acceptable Use Policy (Rules)  •  Interest-Based Ads
Link Copied to Clipboard