Welcome to the updated Slickdeals redesign beta. Learn more and give us feedback. Or, return to the classic view.

Search in
Popular Deal
Rakuten (Buy.com) Discounts, Deals and Coupon Codes

Vivotek TC5331 Wireless IP Surveillance Motion Detect Network Camera - $14.99 at Rakuken /w FS

technoboy 850 March 21, 2014 at 08:34 AM in Free Shipping (6) More Rakuten (Buy.com) Deals
Sorry, this deal has expired. Get notified of deals like this in the future. Add Deal Alert for this Item
Deal
Score
+16
23,693 Views
Buy Now

Deal Details

Vivotek TC5331 Wireless IP Surveillance Motion Detect Network Camera

Link [rakuten.com]
Quote from Bryan1436 View Post :
It's worth noting that you get 10% back in points this weekend, bringing this down to ~ $13.50. Use the promo code "SUPERWKND".

Video Of Setup [youtube.com]

Anyone have one? Recommend?

Webpage interface is in French.

93 Comments

3 4 5 6 7

Sign up for a Slickdeals account to remove this ad.

Joined Jun 2005
L2: Beginner
25 Reputation
#76
Has anyone been able to connect to wifi with WPA security? I've tried downgrading the router security to WPA instead of WPA2, but the cam never seems to be able to connect.
Reply Helpful Comment? 0 0
Joined Dec 2011
L4: Apprentice
174 Reputation
#77
Quote from vector4 View Post :
Awesome, it works great servili. I uploaded the new set of files and was able to setup everything as intended. I got email capture on motion event working and everything.
what email settings do you use, I've tried gmail but no dice... Frown

Quote from bzo View Post :
Has anyone been able to connect to wifi with WPA security? I've tried downgrading the router security to WPA instead of WPA2, but the cam never seems to be able to connect.
same here... unable to get it to connect in wi-fi mode (even to a rooter with security disabled) Frown
Reply Helpful Comment? 0 0
Joined Jan 2010
L3: Novice
30 Reputation
#78
Quote from bzo View Post :
Has anyone been able to connect to wifi with WPA security? I've tried downgrading the router security to WPA instead of WPA2, but the cam never seems to be able to connect.
Quote from relaymy View Post :
same here... unable to get it to connect in wi-fi mode (even to a rooter with security disabled) Frown

I'm going to assume that both of you are running a g/n mixed mode on your router? It seems that this device needs a G only or possibly B/G broadcast in order to work.
Reply Helpful Comment? 0 0
Joined Feb 2013
L1: Learner
10 Reputation
#79
I am running Mixed mode (B/G/N) on my router. I downgraded it to WPA security and it connected right up. Servili's suggestion of being in full mixed mode might be the answer.

I tried gmail smtp settings but my ISP doesn't allow smtp traffic outside of their network (many/most of them do this) so I had to just setup my Suddenlink email account and use their smtp server to send the mail.
Reply Helpful Comment? 0 0
Joined Feb 2012
L10: Grand Master
1,552 Reputation
#80
when it comes to ip cams you are much better off having a separate router so your main router doesnt get bogged down.
Reply Helpful Comment? 0 0
Joined Apr 2014
L1: Learner
10 Reputation
#81
If you are having trouble setting up email for this cam (as I was) you might want to look at using stunnel(stunnel.org). Due to the age of the camera, and perhaps the firmware version, it doesn't appear to support SSL for SMTP which most email providers require. It is a small app that can be run as a service which allows your cam to connect to it without encryption and then it connects to the email provider via SSL. The only downside is that you need a pc that runs 24x7 to run stunnel. Its not ideal but it does work. I am now able to use motion detection and email pics by this method.
Reply Helpful Comment? 0 0
Joined Jan 2006
L4: Apprentice
219 Reputation
#82
Regarding "Edit 3 - Found that I simply had to increase the ramdisk size to ~10m to get the update to have enough room to extract and run, but the first camera I tested on worked up until I Factory Restored it....hmm"

Has anyone else been successful at upgrading to a newer firmware?


Quote from servili007 View Post :
Okay, so, FTP access practically makes this a wide open linux box. One change I Recommend to EVERYONE is to log into the FTP (just point your favorite client at the IP of the device and log in, username root and password is whatever you set). then edit /mnt/flash/etc/network/wireless.conf and change CountryRegion=6 to CountryRegion=0 The default settings are for France and limited to channels 3-9, whereas here we use 1-11, so this could be causing problems for people. Telnet can be enabled from inetd.conf (verified, logged in as root). Editing sysconf and rebooting will let you make everything appear as IP7137, but there is still a firmware mismatch.

Vivotek support unfortunately couldn't provide much help, but that did not surprise me.

It looks like the PCB for these cameras is only missing a couple of components to make them PoE compatible (a couple of bridge rectifiers, a diode, and a cap), but my EE isn't advanced enough to reverse engineer it, in case anyone else is interested.

Edit - Tricked the IW2 app into taking a flash file,but it didn't run successfully.

Edit 2 - In the interim, I'm going to make a translated version using ftp://ftp.vivotek.com/TC5331_Manual_VVTK.pdf as a guideline and share it.

Edit 3 - Found that I simply had to increase the ramdisk size to ~10m to get the update to have enough room to extract and run, but the first camera I tested on worked up until I Factory Restored it....hmm
Reply Helpful Comment? 0 0

Sign up for a Slickdeals account to remove this ad.

Joined Jan 2010
L3: Novice
30 Reputation
#83
Quote from Mawashi View Post :
Regarding "Edit 3 - Found that I simply had to increase the ramdisk size to ~10m to get the update to have enough room to extract and run, but the first camera I tested on worked up until I Factory Restored it....hmm"

Has anyone else been successful at upgrading to a newer firmware?
I really wouldn't attempt it or fixate on it, and I say that after going through three cameras looking for possibilities. We have the web files from the newest firmware, and the biggest limitations for the IP7137 and this unit are that the software is just old (if you've seen the activex viewer and web interface). If someone had an entirely alternate firmware, it might be worth the time, but as it stands these old wifi-g devices really don't command much of anyone's time.
Reply Helpful Comment? 0 0
Joined Feb 2013
L1: Learner
10 Reputation
#84
Quote from servili007 View Post :
I really wouldn't attempt it or fixate on it, and I say that after going through three cameras looking for possibilities. We have the web files from the newest firmware, and the biggest limitations for the IP7137 and this unit are that the software is just old (if you've seen the activex viewer and web interface). If someone had an entirely alternate firmware, it might be worth the time, but as it stands these old wifi-g devices really don't command much of anyone's time.
I'll agree with servili. Seems like the only feature I can find missing is mostly being able to set up multiple events to trigger on. This old firmware only gives you one. But it works.... I can't think of anything more I need this camera to do. The biggest gain was servili updating it to english so I can actually use it without it being a pain in the ass.
Reply Helpful Comment? 0 0
Joined Jan 2006
L4: Apprentice
219 Reputation
#85
Got you, thanks for the clarification and many thanks for the files servili007!
Reply Helpful Comment? 0 0
Joined Jul 2014
L1: Learner
10 Reputation
#86
Quote from bzo View Post :
Has anyone been able to connect to wifi with WPA security? I've tried downgrading the router security to WPA instead of WPA2, but the cam never seems to be able to connect.

I have no trouble connecting with the right setup. My router is set for WPA personal, 20/40mhz, NG Mixed. This camera older unit so it's only going to connect to WPA Personal and G.
Reply Helpful Comment? 0 0
Joined Jul 2014
L1: Learner
10 Reputation
#87
Quote from servili007 View Post :
For those who are familiar and are using FTP and telnet on their devices now, here is a script I made to overwrite your website files with english ones (disclaimer - not responsible for damage). This script makes a full backup of your old www folder first and also copies the old cab for the activeX for double redundancy.
.....

.
servili has done a fine job pulling this together and it works like a charm. Thank you!

I did find that the timezone configuration on the system setup page doesn't work right and tracked it down to a difference in the way the values are handled between the TC5331 and wherever servili pulled it from. I've made some changes in that file to correct the problem and it's attached. Just unzip it and overwrite the "system.html" file in /mnt/flast/www/setup after you've applied servili's script and you are done. Servili, you might want to update your tar file with this.

Cheers,
Ron
Reply Helpful Comment? 0 0
Joined Jan 2010
L3: Novice
30 Reputation
#88
Quote from Wingspinner View Post :
servili has done a fine job pulling this together and it works like a charm. Thank you!

I did find that the timezone configuration on the system setup page doesn't work right and tracked it down to a difference in the way the values are handled between the TC5331 and wherever servili pulled it from. I've made some changes in that file to correct the problem and it's attached. Just unzip it and overwrite the "system.html" file in /mnt/flast/www/setup after you've applied servili's script and you are done. Servili, you might want to update your tar file with this.

Cheers,
Ron
Thanks, I'll update it when I have a moment and reupload. I feel like there may have been other settings that didn't stick properly due to incompatible code, so let me know if you find them.
Reply Helpful Comment? 0 0
Joined Jul 2014
L1: Learner
10 Reputation
#89
Quote from servili007 View Post :
Thanks, I'll update it when I have a moment and reupload. I feel like there may have been other settings that didn't stick properly due to incompatible code, so let me know if you find them.
Yes, I've found some others - like the motion detection page and the video configuration page. Don't use motion detect and the cameras (I have 4 of them) are working fine for my purposes but when I get some spare time I'll fix those pages as well. Also, apparently, the board has 6mb of ramdisk unused and it would be nice to use that to store motion snapshots like later cameras. Not sure why Vivotek isn't doing that already. Perhaps I can borrow some code from my IP8131W to get started. One can ftp it to itself but but it's not very clean.
Reply Helpful Comment? 0 0

Sign up for a Slickdeals account to remove this ad.

Joined Jul 2014
L1: Learner
10 Reputation
#90
Sent PM instead
Reply Helpful Comment? 0 0
Page 6 of 7
3 4 5 6 7
Join the Conversation
Add a Comment
 
Slickdeals Price Tracker
Saving money just got easier.
Start Tracking Today
Copyright 1999 - 2015. Slickdeals, LLC. All Rights Reserved. Copyright / DMCA Notice  •  Privacy Policy  •  Terms of Service  •  Acceptable Use Policy (Rules)