Forum Thread

bluetooth 4.0

sandmans42 2,135 516 March 22, 2016 at 07:21 AM
Ok I'm clueless but is there a way to update bluetooth on a tablet to 4.0? by a type of system update or xda developer root?
I have:
Android 4.4.2 on sero 8.
Android 4.4.1 on sero 7 pro

I believe the default is 3.0 on both.

thanks for any help... or if not, offer a cheap Android alternative with bluetooth 4.0

8 Comments

1

Sign up for a Slickdeals account to remove this ad.

Joined Aug 2005
L10: Grand Master
12,662 Posts
4,824 Reputation
Pro
#2
Not possible, it's a hardware thing not a software thing.

This would be similar to Wireless versions. You cant update your card that only supports wireless N to also support Wireless AC with just a software update. The chips/radio in the card have to support the spec you want.

What is your reason for wanting to do this? There may be another way.
Reply Helpful Comment? 0 0
Vague questions receive vague answers . . . . . .
#3
There are also software considerations, but Bluetooth 4.0 is fully supported in Android 4.4, so I'd agree that there's not much hope of a software fix.
Reply Helpful Comment? 0 0
Joined Feb 2004
L7: Teacher
2,135 Posts
516 Reputation
Original Poster
#4
bummer the treadmill we just got uses 4.0 with an Android app. I appreciate the replies. brand is AFG 5.7AT. we like it anyway and not worth a return but it would have been awesome with this app.
Reply Helpful Comment? 0 0
Joined Aug 2005
L10: Grand Master
12,662 Posts
4,824 Reputation
Pro
#5
Quote from sandmans42 View Post :
bummer the treadmill we just got uses 4.0 with an Android app. I appreciate the replies. brand is AFG 5.7AT. we like it anyway and not worth a return but it would have been awesome with this app.
Most of the time bluetooth like that is backwards compatible. 4.0 does have a low energy profile for stuff like fitness bands etc but I would imagine a treadmill would not be using Low energy. Have you tried setting it up anyways?
Reply Helpful Comment? 0 0
Joined Feb 2004
L7: Teacher
2,135 Posts
516 Reputation
Original Poster
#6
app won't even install. it will install on the android phone LG sunset which I'm assuming is 4.0 but the screen is too small.
Reply Helpful Comment? 0 0
Joined Aug 2005
L10: Grand Master
12,662 Posts
4,824 Reputation
Pro
#7
Quote from sandmans42 View Post :
app won't even install. it will install on the android phone LG sunset which I'm assuming is 4.0 but the screen is too small.
If it won't install I doubt it's because of bluetooth. Could be the app is not designed for tablets of that spec etc. Might be worth contacting the developer. Personally I have had good luck contacting a developer with a app/device issue .
Reply Helpful Comment? 0 0
#8
Knowing something about lazy programmers, I wouldn't be surprised at all if they just reused or licensed code from an existing fitness tracker. Most if not all of those are Bluetooth 4.0 only.
Reply Helpful Comment? 0 0

Sign up for a Slickdeals account to remove this ad.

Joined Feb 2004
L7: Teacher
2,135 Posts
516 Reputation
Original Poster
#9
I contacted the developer and asked for an older version:

Hello,
Thank you for contacting Johnson Health. The 5.7AT is only compatiable with Andriod tablets and iPads that have Bluetooth verison 4.0. Any other verison of Bluetooth is not compatiable. The 5.7AT is also not compatiable with cellphones. There is not an older verison available.
Reply Helpful Comment? 0 0
Page 1 of 1
1
Join the Conversation
Add a Comment
 
Copyright 1999 - 2016. Slickdeals, LLC. All Rights Reserved. Copyright / Infringement Policy  •  Privacy Policy  •  Terms of Service  •  Acceptable Use Policy (Rules)  •  Interest-Based Ads
Link Copied to Clipboard