Forum Thread

Slickdeals taking lot of CPU on mac chrome

609 115 June 9, 2018 at 10:28 PM
Slickdeals take lot of CPU in chrome. Attaching screenshot of chrome taskmanager.

7 Comments

1

Sign up for a Slickdeals account to remove this ad.

This comment has been rated as unhelpful by Slickdeals users
Joined May 2005
L5: Journeyman
609 Posts
115 Reputation
Original Poster
#2
no response ? I am literally afraid of opening slickdeals now since it drains battery so fast (with fan on full blast).
Reply Helpful Comment? 0 0
This comment has been rated as unhelpful by Slickdeals users
Joined Jun 2017
Web Developer
132 Posts
73 Reputation
Web Dev
#3
Quote from meranamjoker
:
no response ? I am literally afraid of opening slickdeals now since it drains battery so fast (with fan on full blast).
Hey there, sorry you're running into this issue. What browser and device are you using to browse SD? Our site alone should not be consuming too much CPU on a standard device, however you might be encountering a page ad which is consuming processing time on your device. These ads are rare and can occasionally slip through the ad networks quality checks, so we're always working to track down and remove these ads with unwanted side effects.

I would recommend trying to clear your site cookies and storage to see if you can get rid of the CPU eating ad, and otherwise please let us know which ads you're seeing (their URLs) so we can take a look into them and whether they should be removed from our site.

If you continue seeing the site run on a constant 100% after clearing cookies / etc, then you can always adblock us Frown .
Reply Helpful Comment? 0 0
This comment has been rated as unhelpful by Slickdeals users
Joined May 2005
L5: Journeyman
609 Posts
115 Reputation
Original Poster
#4
BTW I am already using ublock origin so ads are already blocked.
Attaching the javascript profile. Maybe this will help you debug the issue.
Click image for larger version

Name:	Screen Shot 2018-06-15 at 5.16.21 PM.png
Views:	27
Size:	659.0 KB
ID:	7027719
Reply Helpful Comment? 0 0
This comment has been rated as unhelpful by Slickdeals users
Joined Jun 2017
Web Developer
132 Posts
73 Reputation
Web Dev
#5
Quote from meranamjoker
:
BTW I am already using ublock origin so ads are already blocked.
Attaching the javascript profile. Maybe this will help you debug the issue.
Attachment 7027719
Thanks for that screenshot, from what I see that profile looks fine. What browser / OS are you using? On chrome & OSX I'm getting standard website CPU usage, nothing out of the ordinary.

EDIT: Laptop or desktop?
Reply Helpful Comment? 0 0
This comment has been rated as unhelpful by Slickdeals users
Joined May 2005
L5: Journeyman
609 Posts
115 Reputation
Original Poster
#6
Chrome on OX. Laptop. But just tried resetting everyone on browser and now it is back to sane usage. So must be something lingering around in my browser's cache.
Reply Helpful Comment? 0 0
This comment has been rated as unhelpful by Slickdeals users
Joined Jun 2017
Web Developer
132 Posts
73 Reputation
Web Dev
#7
Quote from meranamjoker
:
Chrome on OX. Laptop. But just tried resetting everyone on browser and now it is back to sane usage. So must be something lingering around in my browser's cache.
Weird, feel free to send me a PM or reply to this post if you see the issue again. Glad it's back to normal!
Reply Helpful Comment? 0 0
This comment has been rated as unhelpful by Slickdeals users
Joined May 2011
L3: Novice
207 Posts
90 Reputation
#8
install ABP and Ghostery, along with Little Snitch in demo mode 3hrs.
Reply Helpful Comment? 0 0
Page 1 of 1
1
Join the Conversation
Add a Comment
 
Link Copied to Clipboard