Forum Thread

TP-Link Deco M9 Plus Tri-Band WiFi (3-Pack) $199.99 Costco

+5 Deal Score
4,422 Views
TP-Link Deco M9 Plus Tri-Band Wi-Fi System with Built-In Smart Hub, 3-pack

Though this seems like Costco's regular price, I consider this a deal since the 2-Pack is on sale/goes for $199.99 other places.

https://www.costco.com/tp-link-de...77095.html
Share
Good deal?
You gave thanks to ksimm033 for this post.
Thank you!
ksimm033 posted this deal. Say thanks!
If you purchase something through a post on our site, Slickdeals may get a small share of the sale.
Deal
Score
+5
4,422 Views

36 Comments

1 2 3

Sign up for a Slickdeals account to remove this ad.

This comment has been rated as unhelpful by Slickdeals users
Joined Dec 2008
L3: Novice
241 Posts
40 Reputation
#16
Quote from ABOk211
:
Have you received any shipping information? I order mine on Thursday and still nothing. I ordered a garage light from them and it was shipped and delivered in a week.
I ordered it on Thursday and it was delivered UPS on Saturday. I am in Southern California. Set up was pretty straightforward, it took me about 15 minutes. So far everything seems to be working good. Getting my full 150 mbs with Cox.
0
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined May 2008
L5: Journeyman
549 Posts
198 Reputation
#17
Back in stock
0
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined Mar 2015
L3: Novice
203 Posts
22 Reputation
#18
Added to cart, but won't let me check out, oos again
0
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined Nov 2007
L3: Novice
104 Posts
35 Reputation
#19
Lucky you! I ordered mine on May 10th, and it still hasn't shipped.
I also live in SOCAL. I've tried Costco's live chat and called.
No one has been able to tell me why it hasn't shipped. All the tell me is "when it ships, you'll get an email". Sweet. Mad

Quote from socal_doc
:
I ordered it on Thursday and it was delivered UPS on Saturday. I am in Southern California. Set up was pretty straightforward, it took me about 15 minutes. So far everything seems to be working good. Getting my full 150 mbs with Cox.
0
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined Feb 2010
L1: Learner
17 Posts
20 Reputation
#20
Quote from olivernorth23
:
Lucky you! I ordered mine on May 10th, and it still hasn't shipped.
I also live in SOCAL. I've tried Costco's live chat and called.
No one has been able to tell me why it hasn't shipped. All the tell me is "when it ships, you'll get an email". Sweet. Mad
Ordered May 8 got an email tonight that it shipped and should be here Tuesday.
1
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined May 2014
New User
10 Posts
10 Reputation
#21
Quote from revaldo29
:
What kind of speeds are people able to get these when using wireless back haul?
I have 200 Mbps service which usually means ~220 down. I'm able to get that with a wi-fi connection from any of the APs connected to ethernet backhaul, though I am having an issue where anything ethernet connected (to the main unit, including the APs via backhaul) periodically tops out at 150-175. When that happens. obviously can't get 220 from anything but wi-fi to main Deco. Still need to work that out with TP-Link tech support.
0
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined Nov 2010
L3: Novice
298 Posts
86 Reputation
#22
Quote from revaldo29
:
What kind of speeds are people able to get these when using wireless back haul?
I bought this last week and connected it with my AT&T internet. I am getting 200 MB Up & 200 Down most of the time with my Gigabit service (with Ethernet Backhaul using POE or without it). It is disappointing to be honest since I am able to get 600+ connecting to AT&T router via Ethernet.

I suspect AT&T router/modem combo is to blame though since you can't really by-pass it completely and I have to have Deco behind the AT&T router. It may be limiting the speed but even then, signal reliability has been spotty at best. I have been dropped out of conference calls even after installing this.
0
0
0
0
Reply

Sign up for a Slickdeals account to remove this ad.

This comment has been rated as unhelpful by Slickdeals users
Joined Nov 2007
L3: Novice
104 Posts
35 Reputation
#23
Thanks Swideen! That gives me some hope. Maybe mine will ship out tomorrow night then. *fingers crossed*

Quote from swideen
:
Ordered May 8 got an email tonight that it shipped and should be here Tuesday.
1
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined Nov 2009
L4: Apprentice
306 Posts
82 Reputation
#24
Quote from olivernorth23
:
Thanks Swideen! That gives me some hope. Maybe mine will ship out tomorrow night then. *fingers crossed*
Ordered on the 13th and still hasn't shipped yet
0
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined Feb 2006
Master of Cheapness
619 Posts
102 Reputation
#25
I bought this a week ago and tested it out. I have a long rectangular, 3-story house, about 1,500 SF each floor. My modem/main unit is right in the middle of the house (middle of the 2nd floor), and I have a satellite on each of the 1st and 3rd floors (nearly same spot on each floor). The signal strength is horrible more than 20 ft away from each node (same room I get download speds of 200 mbps, but just 1 room over, it drops to 20-30mbps, and 40-50 feet I barely get any signal). My house is a brick house and the walls are plaster (i think).

My old urlhasbeenblocked Nova MW6 ac1200 mesh network gets better signal than this. But same thing happened when i tried the Eero. Will the Orbi RBK53 do better? Thinking of trying it since it is ac3300. Any idea?
0
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined Nov 2009
L4: Apprentice
306 Posts
82 Reputation
#26
Quote from cheapbrass
:
I bought this a week ago and tested it out. I have a long rectangular, 3-story house, about 1,500 SF each floor. My modem/main unit is right in the middle of the house (middle of the 2nd floor), and I have a satellite on each of the 1st and 3rd floors (nearly same spot on each floor). The signal strength is horrible more than 20 ft away from each node (same room I get download speds of 200 mbps, but just 1 room over, it drops to 20-30mbps, and 40-50 feet I barely get any signal). My house is a brick house and the walls are plaster (i think).

My old urlhasbeenblocked Nova MW6 ac1200 mesh network gets better signal than this. But same thing happened when i tried the Eero. Will the Orbi RBK53 do better? Thinking of trying it since it is ac3300. Any idea?
is this because you're connected to 5ghz and not 2.5ghz?
0
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined Apr 2006
L7: Teacher
2,843 Posts
572 Reputation
#27
Quote from sd8384
:
I bought this last week and connected it with my AT&T internet. I am getting 200 MB Up & 200 Down most of the time with my Gigabit service (with Ethernet Backhaul using POE or without it). It is disappointing to be honest since I am able to get 600+ connecting to AT&T router via Ethernet.

I suspect AT&T router/modem combo is to blame though since you can't really by-pass it completely and I have to have Deco behind the AT&T router. It may be limiting the speed but even then, signal reliability has been spotty at best. I have been dropped out of conference calls even after installing this.
I have C4000 one unit router on Verizon gigabit, from the app, I can test the speed of internet at 800MB up/down, from remote devices, I got about 200MB up/down, so it's more or less the speed limit for the WiFi. For 2.4GHz AG network, it's around 30MB max. I don't know if that new WiFi 6 router at $400 will have any better throughput.
I don't have AT&T, but you should have the option of the fiber unit direct Ethernet out, which is what I have on my Verizon, fiber Ethernet to WiFi Wan port.
0
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined Nov 2010
L3: Novice
298 Posts
86 Reputation
#28
Quote from FAMIR
:
I have C4000 one unit router on Verizon gigabit, from the app, I can test the speed of internet at 800MB up/down, from remote devices, I got about 200MB up/down, so it's more or less the speed limit for the WiFi. For 2.4GHz AG network, it's around 30MB max. I don't know if that new WiFi 6 router at $400 will have any better throughput.
I don't have AT&T, but you should have the option of the fiber unit direct Ethernet out, which is what I have on my Verizon, fiber Ethernet to WiFi Wan port.
200MB is plenty speed at the remote device but the issue is inconsistent output. The upload speed stays consistent 200 MB but download speed varies from 10MB to 380MB and I haven't been able to find variable that causes speed decrease. I am trying to move the Decos around to find best setup but I might as well go back to my Dual Ac1750 routers. Speed was less but it felt more consistent.

Also, i don't think AT&T has option to Ethernet out bypassing their unit. I however has been getting slightly better result by doing Mac Clone on Deco.
0
0
0
0
Reply
This comment has been rated as unhelpful by Slickdeals users
Joined Nov 2010
L3: Novice
298 Posts
86 Reputation
#29
Quote from cheapbrass
:
I bought this a week ago and tested it out. I have a long rectangular, 3-story house, about 1,500 SF each floor. My modem/main unit is right in the middle of the house (middle of the 2nd floor), and I have a satellite on each of the 1st and 3rd floors (nearly same spot on each floor). The signal strength is horrible more than 20 ft away from each node (same room I get download speds of 200 mbps, but just 1 room over, it drops to 20-30mbps, and 40-50 feet I barely get any signal). My house is a brick house and the walls are plaster (i think).

My old urlhasbeenblocked Nova MW6 ac1200 mesh network gets better signal than this. But same thing happened when i tried the Eero. Will the Orbi RBK53 do better? Thinking of trying it since it is ac3300. Any idea?
My experience is very similar to yours. I have placed the devices where I use it most but it is disappointing solution.
0
0
0
0
Reply

Sign up for a Slickdeals account to remove this ad.

This comment has been rated as unhelpful by Slickdeals users
Joined May 2017
New User
9 Posts
10 Reputation
#30
I just received my shipping email! I ordered it on the 14th.
0
0
0
0
Reply
Page 2 of 3
1 2 3
Join the Conversation
Add a Comment
 

Link Copied to Clipboard